package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<actor=(\w+)(\s(?'kword1'\w+)(=(?'val1'\w+))?)?(\s(?'kword2'.+?)(=(?'val2'\w+))?)?(\s(?'kword3'.+?)(=(?'val3'\w+))?)?(\s(?'kword4'.+?)(=(?'val4'.+?))?)?>`)
var str = `<actor=vencil lookat=beatrice enter transfer=vencil set="Vencil 1">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}