const regex = /<actor=(\w+)(\s(?'kword1'\w+)(=(?'val1'\w+))?)?(\s(?'kword2'.+?)(=(?'val2'\w+))?)?(\s(?'kword3'.+?)(=(?'val3'\w+))?)?(\s(?'kword4'.+?)(=(?'val4'.+?))?)?>/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<actor=(\\w+)(\\s(?\'kword1\'\\w+)(=(?\'val1\'\\w+))?)?(\\s(?\'kword2\'.+?)(=(?\'val2\'\\w+))?)?(\\s(?\'kword3\'.+?)(=(?\'val3\'\\w+))?)?(\\s(?\'kword4\'.+?)(=(?\'val4\'.+?))?)?>', 'gs')
const str = `<actor=vencil lookat=beatrice enter transfer=vencil set="Vencil 1">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}