$re = '/((?\'col\'\D)(?\'dig\'\d\d))$/m';
$str = '10:00:00:01';
$subst = ";$dig";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;