# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/("(?:\\.|[^"\\])*"|'(?:\\.|[^'\\])*')/Subbed/g;t' <<< "/*
this is comment block and should not be processed
var charName = \"johnson\";
*/
var charName = \"Alex\";"