re = /^(@(typescript-)?eslint\/.*|eslint($|(?!.*next).*))/m
str = 'eslint
@eslint/js
eslint-config-prettier
eslint-plugin-next
eslint-plugin-import
eslint-config-foxkit
@typescript-eslint/parser
@typescript-eslint/eslint-plugin'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end