const regex = /((?:src|href)\s*=\s*")((?!{{\s*asset)[^"]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:src|href)\\s*=\\s*")((?!{{\\s*asset)[^"]+)', 'gm')
const str = `<img src="icons/google-icon.svg" >
//Replace to:
<img src="{{asset('icons/google-icon.svg')}}" >
//Find:
<link href="css/style.css">
//Replace to:
<link href="{{asset('css/style.css')}}">`;
const subst = `$1{{asset('$2')}}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);