$re = '/((?:src|href)\s*=\s*")((?!{{\s*asset)[^"]+)/m';
$str = '<img src="icons/google-icon.svg" >
//Replace to:
<img src="{{asset(\'icons/google-icon.svg\')}}" >
//Find:
<link href="css/style.css">
//Replace to:
<link href="{{asset(\'css/style.css\')}}">';
$subst = "$1{{asset('$2')}}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;