const regex = /(https?:\/\/.*\.(?:png|jpg)\?w=[0-9]+&crop=[0-9])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/.*\\.(?:png|jpg)\\?w=[0-9]+&crop=[0-9])', 'gm')
const str = `https://spy.com/wp-content/uploads/2022/01/Roborock-S6-Pure-Featured.jpg?w=232&crop=1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}