re = /(.*?)\s(.*)\s(.*)/m
str = 'Шихман-Соколовский Исаак бюль-бюль оглы аль Рахман Ааронович'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end