#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)(<a[^>]*>[^<]*<img[^>]*>[^<]*<\/a>)\r?\n?"
Local $sString = "<a href="/in-bai-viet--Choang-n20120711033726647.chn" target="_blank">In<img src="/Images/printer.png" alt="In bài viết này" />" & @CRLF & _
"</a>" & @CRLF & _
"<a target="_blank" rel="nofollow" href="http://ttvn.vn/">Thiên Lam - TTVN" & @CRLF & _
"</a>" & @CRLF & _
"<a href="/tinh-yeu-hon-nhan/20120709102954599/Chay-lang-.chn" title="'abc'">" & @CRLF & _
"abcd" & @CRLF & _
"</a>" & @CRLF & _
"<a href="/in-bai-viet--Choang-n20120711033726647.chn" target="_blank">In<img src="/Images/printer.png" alt="In bài viết này" />" & @CRLF & _
"</a>" & @CRLF & _
"<a target="_blank" rel="nofollow" href="http://ttvn.vn/">Thiên Lam - TTVN" & @CRLF & _
"</a>" & @CRLF & _
"<a href="/tinh-yeu-hon-nhan/20120709102954599/Chay-lang-.chn" title="'abc'">" & @CRLF & _
"abcd" & @CRLF & _
"</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")