use strict;
my $str = '<a href="/in-bai-viet--Choang-n20120711033726647.chn" target="_blank">In<img src="/Images/printer.png" alt="In bài viết này" />
</a>
<a target="_blank" rel="nofollow" href="http://ttvn.vn/">Thiên Lam - TTVN
</a>
<a href="/tinh-yeu-hon-nhan/20120709102954599/Chay-lang-.chn" title="\'abc\'">
abcd
</a>
<a href="/in-bai-viet--Choang-n20120711033726647.chn" target="_blank">In<img src="/Images/printer.png" alt="In bài viết này" />
</a>
<a target="_blank" rel="nofollow" href="http://ttvn.vn/">Thiên Lam - TTVN
</a>
<a href="/tinh-yeu-hon-nhan/20120709102954599/Chay-lang-.chn" title="\'abc\'">
abcd
</a>';
my $regex = qr/(<a[^>]*>[^<]*<img[^>]*>[^<]*<\/a>)\r?\n?/sip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}