package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^([A-Z|a-z|0-9]{4},)*[A-Z|a-z|0-9]{4}$`)
var str = `COM1,COM2,COM3,1234
COM,1234,COM,1234
1234,1234,34F
1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}