#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[[0-9]+[;]?[1H\[K\[7mlines [0-9-]+ \[[0-9]+m\[60;1H\[60;1H"
Local $sString = "[60;1H[K[7mlines 17464-17522 [27m[60;1H[60;1H[K 140.90.101.62-NOAA {" & @CRLF & _
" ip-netmask 140.90.101.62;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA National Center for Environmental Prediction - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 140.172.138.17-NOAA {" & @CRLF & _
" ip-netmask 140.172.138.17;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA Operational Model Archive and Distro System (NOMADS-HTTPS) National Center for Environmental Prediction (NCEP-FTP) - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 128.132.41.26-AFRL {" & @CRLF & _
" ip-netmask 128.132.41.26;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - CAOC AF Research Lab - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 140.172.138.18-NOAA {" & @CRLF & _
" ip-netmask 140.172.138.18;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA Operational Model Archive and Distro System - HTTPS - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 204.0.3.146 {" & @CRLF & _
" ip-netmask 204.0.3.146;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - Intellicast - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 192.145.239.17 {" & @CRLF & _
" ip-netmask 192.145.239.17;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - Hurrtrack - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 70.39.145.13 {" & @CRLF & _
" ip-netmask 70.39.145.13;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - Hurrtrack - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 204.0.3.147 {" & @CRLF & _
" ip-netmask 204.0.3.147;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - Intellicast - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 140.172.17.191-NOAA {" & @CRLF & _
" ip-netmask 140.172.17.191;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA Aviation Weather Center - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 140.90.200.191-NOAA {" & @CRLF & _
" ip-netmask 140.90.200.191;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA Aviation Weather Center - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 129.15.96.191-NOAA {" & @CRLF & _
" ip-netmask 129.15.96.191;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA Aviation Weather Center - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 23.3.96.193-NOAA {" & @CRLF & _
" ip-netmask 23.3.96.193;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA - NWS Radar Sites - Contact WCOC DSN 271-2586";" & @CRLF & _
"[60;1H[K[7mlines 17523-17581 [27m[60;1H[60;1H[K }" & @CRLF & _
" 205.156.4.51-NOAA {" & @CRLF & _
" ip-netmask 205.156.4.51;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA - Web Map Service - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 23.3.96.242-NOAA {" & @CRLF & _
" ip-netmask 23.3.96.242;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA - NWS Radar Sites - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 199.212.17.28 {" & @CRLF & _
" ip-netmask 199.212.17.28;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - Canadian Weather - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 199.212.17.39 {" & @CRLF & _
" ip-netmask 199.212.17.39;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - Canadian Weather - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 192.139.6.68 {" & @CRLF & _
" ip-netmask 192.139.6.68;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - Canadian Northern Forestry Center - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 140.90.101.79-NOAA {" & @CRLF & _
" ip-netmask 140.90.101.79;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA NWS/NCEP TGFTP server - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 140.90.101.34-NOAA {" & @CRLF & _
" ip-netmask 140.90.101.34;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA NWS/NCEP FTP HPC Anony server - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 140.90.101.132-NOAA {" & @CRLF & _
" ip-netmask 140.90.101.132;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA NWS/NCEP Wind/Wave server - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 140.172.138.79-NOAA {" & @CRLF & _
" ip-netmask 140.172.138.79;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA NWS/NCEP TGFTP server - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 140.90.213.161-NOAA {" & @CRLF & _
" ip-netmask 140.90.213.161;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA NESDIS server - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 140.90.195.198-NOAA {" & @CRLF & _
" ip-netmask 140.90.195.198;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA National Center for Environmental Prediction - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 140.90.192.168-NOAA {" & @CRLF & _
" ip-netmask 140.90.192.168;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
"[60;1H[K[7mlines 17582-17640 [27m[60;1H[60;1H[K description "Weather - NOAA National Center for Environmental Prediction - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 128.118.28.249-PSU {" & @CRLF & _
" ip-netmask 128.118.28.249;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - Penn State Uni Bufkit - apps2.meteo.psu.edu - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 140.90.128.71-NOAA {" & @CRLF & _
" ip-netmask 140.90.128.71;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA National Center for Environmental Prediction - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 140.90.88.142-NOAA {" & @CRLF & _
" ip-netmask 140.90.88.142;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA National Center for Environmental Prediction - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 140.90.33.41-NOAA {" & @CRLF & _
" ip-netmask 140.90.33.41;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA National Center for Environmental Prediction - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 140.90.33.31-NOAA {" & @CRLF & _
" ip-netmask 140.90.33.31;" & @CRLF & _
" tag GLOBAL-WEATHER;" & @CRLF & _
" description "Weather - NOAA National Center for Environmental Prediction - Contact WCOC DSN 271-2586";" & @CRLF & _
" }" & @CRLF & _
" 144.183.222.21 {" & @CRLF & _
" ip-netmask 144.183.222.21;" & @CRLF & _
" }" & @CRLF & _
" 144.183.32.21 {" & @CRLF & _
" ip-netmask 144.183.32.21;" & @CRLF & _
" }" & @CRLF & _
" 199.124.100.0_22 {" & @CRLF & _
" ip-netmask 199.124.100.0/22;" & @CRLF & _
" }" & @CRLF & _
" 199.124.104.0_23 {" & @CRLF & _
" ip-netmask 199.124.104.0/23;" & @CRLF & _
" }" & @CRLF & _
" 199.124.96.15-199.124.96.18 {" & @CRLF & _
" ip-range 199.124.96.15-199.124.96.18;" & @CRLF & _
" }" & @CRLF & _
" 199.225.7.15 {" & @CRLF & _
" ip-netmask 199.225.7.15;" & @CRLF & _
" }" & @CRLF & _
" 214.2.155.12-214.2.155.231 {" & @CRLF & _
" ip-range 214.2.155.12-214.2.155.231;" & @CRLF & _
" }" & @CRLF & _
" 214.2.2.245 {" & @CRLF & _
" ip-netmask 214.2.2.245;" & @CRLF & _
" }" & @CRLF & _
" 214.2.2.246 {" & @CRLF & _
" ip-netmask 214.2.2.246;" & @CRLF & _
" }" & @CRLF & _
" 214.2.90.222 {" & @CRLF & _
" ip-netmask 214.2.90.222;" & @CRLF & _
" }" & @CRLF & _
" 134.11.168.17 {" & @CRLF & _
" ip-netmask 134.11.168.17;" & @CRLF & _
"[60;1H[K[7mlines 17641-17699 [27m[60;1H[60;1H[K description "Pentagon Army ROVR destination";" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")