# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=(?:\d,?){1,10}(?:\.\d{2})?$)[0-9]{1,3}(?:,[0-9]{3})*(?:\.[0-9]+)?$"
test_str = ("I want to make sure that the input is no more than 10 digits before the decimals point so it will match DECIMAL(12,2).\n\n"
"I already tried :\n\n"
"^(?=.{0,13}$)[0-9]{1,3}(,[0-9]{3})*(\\.[0-9]+)?$\n"
"But it counts the digits after decimals too, so what I want to match is:\n\n"
"1,111,111,111.00\n\n"
"so it will keep matching with or without the decimals, what I tried only can match with:\n\n"
"1,111,111,111\n\n"
"111,111,111.00\n\n"
"1,111,111,111,1.00")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.