using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*youtube)(?=.*cat)";
string input = @"This lookahead search is case sensitive.
This this have cat in it?
Does this make a match for Youtube?
What about this youtube and CAT?
What about cat and YOUTUBE?
Here is youtube and cat
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}