#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)01(\d{6,})(10(\S{6,})17(\d{6})|17(\d{6})10(\S{6,}))"
Local $sString = "012900553100156910240909077717270909" & @CRLF & _
"" & @CRLF & _
"0155413760137549172802291025C26T2C" & @CRLF & _
"" & @CRLF & _
"01290055310015691024100909077717270909 #is this what you want?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")