package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:.*lib)?([^\\.*]*)\\`)
var str = `C:\folder0\folder1\folder2\libtest\folder3\folder4\folder5`
var substitution = "$1/"
fmt.Println(re.ReplaceAllString(str, substitution))
}