import Foundation
let pattern = #"(?:.*lib)?([^\\.*]*)\\"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"C:\folder0\folder1\folder2\libtest\folder3\folder4\folder5"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)