#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Name:\s+(.*)[\s\S]*"
Local $sString = " Name: EuroPayment Services S.R.L." & @CRLF & _
" Address: Str. Ion Cămpineanu, nr. 11, Bloc Union, etaj 8, camera 803" & @CRLF & _
" Name: General Motors S.R.L." & @CRLF & _
" Address: Str. Ion Cămpineanu, nr. 11, Bloc Union, etaj 8, camera 803"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")