package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){{[a-zA-z0-9]*|}}`)
var str = `Blah blah {{tag1}} blah {{tag2}} blah`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}