import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^@\\s]+@[^@\\s]+\\.(?!gov(?:\\s|$))[^@\\s.]+)";
final String string = "abc123@abc.c # 'o' is in 'gov' so it ends the returned string there\n"
+ "456@email.edu\n"
+ "governmentemail@governmentaddress. #'.gov' omitted\n"
+ "test@test.gov\n"
+ "test.test@test.org.gov.test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}