# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+)\s+([-.a-zA-Z\s,'À-úÀ-ÿ()?\/\d]+?)\s{2,}([-.a-zA-Z\s,'À-úÀ-ÿ()?\/\d]+?)\s{2,}(I|PF|MA)\s{2,}(I|PF|PL|LI|MA|CV|MJ)\s{2,}(\w+)\s{2,}(\d+,\d{4})"
test_str = ("2236 ARGEMIRO PATROCINIO ARGEMIRO I I UBC 3,8462\n\n"
"1150721 ZACHARY F CONDON ZACH CONDON I I FINTAGE 8,3333\n\n"
"50300 COMERCIAL FONOGRAFICA RGE LTDA. PF LI ABRAMUS 25,0000")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.