# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^abc]*?)(a)|(b)|(c)|(ab)|(ba)|(ac)|(ca)|(bc)|(cb)|(abc)|(acb)|(bac)|(bca)|(cab)|(cba)/$1${2:+b}${3:+c}${4:+a}${5:+bc}${6:+cb}${7:+ba}${8:+ab}${9:+ca}${10:+ac}${11:+bca}${12:+bac}${13:+cba}${14:+cab}${15:+abc}${16:+acb}/gm;t' <<< "abracadabra
a b c
aa bb cc
ab ac ba bc ca cb
abc acb bac bca cab cba"