using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^abc]*?)(a)|(b)|(c)|(ab)|(ba)|(ac)|(ca)|(bc)|(cb)|(abc)|(acb)|(bac)|(bca)|(cab)|(cba)";
string substitution = @"$1${2:+b}${3:+c}${4:+a}${5:+bc}${6:+cb}${7:+ba}${8:+ab}${9:+ca}${10:+ac}${11:+bca}${12:+bac}${13:+cba}${14:+cab}${15:+abc}${16:+acb}";
string input = @"abracadabra
a b c
aa bb cc
ab ac ba bc ca cb
abc acb bac bca cab cba";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}