// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^abc]*?)(a)|(b)|(c)|(ab)|(ba)|(ac)|(ca)|(bc)|(cb)|(abc)|(acb)|(bac)|(bca)|(cab)|(cba)").unwrap();
let string = "abracadabra
a b c
aa bb cc
ab ac ba bc ca cb
abc acb bac bca cab cba";
let substitution = "$1${2:+b}${3:+c}${4:+a}${5:+bc}${6:+cb}${7:+ba}${8:+ab}${9:+ca}${10:+ac}${11:+bca}${12:+bac}${13:+cba}${14:+cab}${15:+abc}${16:+acb}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}