re = /(?<='constant_string' \: )([A-Za-z0-9_])*/m
str = '\'constant_string\' : s
\'constant_string\' : some_string
\'constant_string\' : some_string
\'constant_string\' : some_string
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end