package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z][a-z-]+)([A-Z][a-z-]+)`)
var str = `BorisovaSvetlana A.; KimHak Joong; PuXiaotao; LiuHung-wen*Liu-wenHung-wen*Liu-wen-benHung-wen-ben*PushpeshRajwanshi
`
var substitution = "\1, \2"
fmt.Println(re.ReplaceAllString(str, substitution))
}