const regex = /([A-Z][a-z-]+)([A-Z][a-z-]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z][a-z-]+)([A-Z][a-z-]+)', 'gm')
const str = `BorisovaSvetlana A.; KimHak Joong; PuXiaotao; LiuHung-wen*Liu-wenHung-wen*Liu-wen-benHung-wen-ben*PushpeshRajwanshi
`;
const subst = `\1, \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);