// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([A-Z][a-z-]+)([A-Z][a-z-]+)").unwrap();
let string = "BorisovaSvetlana A.; KimHak Joong; PuXiaotao; LiuHung-wen*Liu-wenHung-wen*Liu-wen-benHung-wen-ben*PushpeshRajwanshi
";
let substitution = "\\1, \\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}