import Foundation
let pattern = #"([A-Z][a-z-]+)([A-Z][a-z-]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
BorisovaSvetlana A.; KimHak Joong; PuXiaotao; LiuHung-wen*Liu-wenHung-wen*Liu-wen-benHung-wen-ben*PushpeshRajwanshi
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1, \2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)