#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)wp\.i18n\.setLocaleData\(\s*localeData,\s*domain\s*\);\s*}\s*\)\s*\(\s*"[^"]+",\s*(.*)\)\s*;\s*<\/script>"
Local $sString = "<script type="text/javascript" id="seopress-metabox-js-translations">" & @CRLF & _
"( function( domain, translations ) {" & @CRLF & _
" /*var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;" & @CRLF & _
" localeData[""].domain = domain;*/" & @CRLF & _
" console.log(translations);" & @CRLF & _
" //wp.i18n.setLocaleData( localeData, domain );" & @CRLF & _
"} )( "wp-seopress", { "test1": "https://www.youtube.com/watch?v=sT1KpjKbsTk" } );" & @CRLF & _
"</script>" & @CRLF & _
"" & @CRLF & _
"<script type="text/javascript" id="seopress-metabox-js-translations">" & @CRLF & _
"( function( domain, translations ) {" & @CRLF & _
" /*var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;" & @CRLF & _
" localeData[""].domain = domain;*/" & @CRLF & _
" console.log(translations);" & @CRLF & _
" //wp.i18n.setLocaleData( localeData, domain );" & @CRLF & _
"} )( "wp-seopress", { "test1": "https://www.youtube.com/watch?v=sT1KpjKbsTk", "test2": "<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/2aeObDtptdE\" title=\"YouTube video player\" frameborder=\"0\" allow=\"accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture\" allowfullscreen></iframe>" } );" & @CRLF & _
"</script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")