use strict;
my $str = '<script type="text/javascript" id="seopress-metabox-js-translations">
( function( domain, translations ) {
/*var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
localeData[""].domain = domain;*/
console.log(translations);
//wp.i18n.setLocaleData( localeData, domain );
} )( "wp-seopress", { "test1": "https://www.youtube.com/watch?v=sT1KpjKbsTk" } );
</script>
<script type="text/javascript" id="seopress-metabox-js-translations">
( function( domain, translations ) {
/*var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
localeData[""].domain = domain;*/
console.log(translations);
//wp.i18n.setLocaleData( localeData, domain );
} )( "wp-seopress", { "test1": "https://www.youtube.com/watch?v=sT1KpjKbsTk", "test2": "<iframe width=\\"560\\" height=\\"315\\" src=\\"https://www.youtube.com/embed/2aeObDtptdE\\" title=\\"YouTube video player\\" frameborder=\\"0\\" allow=\\"accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture\\" allowfullscreen></iframe>" } );
</script>';
my $regex = qr/wp\.i18n\.setLocaleData\(\s*localeData,\s*domain\s*\);\s*}\s*\)\s*\(\s*"[^"]+",\s*(.*)\)\s*;\s*<\/script>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}