import Foundation
let pattern = #"wp\.i18n\.setLocaleData\(\s*localeData,\s*domain\s*\);\s*}\s*\)\s*\(\s*"[^"]+",\s*(.*)\)\s*;\s*<\/script>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<script type="text/javascript" id="seopress-metabox-js-translations">
( function( domain, translations ) {
/*var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
localeData[""].domain = domain;*/
console.log(translations);
//wp.i18n.setLocaleData( localeData, domain );
} )( "wp-seopress", { "test1": "https://www.youtube.com/watch?v=sT1KpjKbsTk" } );
</script>
<script type="text/javascript" id="seopress-metabox-js-translations">
( function( domain, translations ) {
/*var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
localeData[""].domain = domain;*/
console.log(translations);
//wp.i18n.setLocaleData( localeData, domain );
} )( "wp-seopress", { "test1": "https://www.youtube.com/watch?v=sT1KpjKbsTk", "test2": "<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/2aeObDtptdE\" title=\"YouTube video player\" frameborder=\"0\" allow=\"accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture\" allowfullscreen></iframe>" } );
</script>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)