import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(?:\"([^\"]*)\"|([^,\"\"<>]*))?\\s*(?:(?:,|<|\\s+|^)([^<@\\s,]+@[^>@\\s,]+)>?)\\s*";
final String string = "Test1 <test1@x.com>, Test Two test2@x.y.com,T e s t 3 <test3@z.com>, Test@4 <test4@abc.com>, test5@cde.com,\n"
+ "\"Bob Smith\" <bob@company.com>, joe@company.com, \"John Doe\"<john@company.com>, Billy Doe<billy@company.com>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}