re = /\s*(?:"([^"]*)"|([^,""<>]*))?\s*(?:(?:,|<|\s+|^)([^<@\s,]+@[^>@\s,]+)>?)\s*/m
str = 'Test1 <test1@x.com>, Test Two test2@x.y.com,T e s t 3 <test3@z.com>, Test@4 <test4@abc.com>, test5@cde.com,
"Bob Smith" <bob@company.com>, joe@company.com, "John Doe"<john@company.com>, Billy Doe<billy@company.com>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end