using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+,)+\d+$";
string input = @"1,2,3,495,5
1,2,3,45,
,12,4,2,67
1,2 3,4,5,6
1,2,3,49,5
1234,5555,2,2555";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}