use strict;
my $str = '<html>
<head>
<title>Test</title>
</head>
<body>
<div> <a href="test1.html" title="test"></a>
<?php
$result_array="123";
if ($result_array=="123")
{
?>
<a href="test4.html" title="tesdfhdfhdfht2"></a>
<?php
else{
?>
<a href="test5.html" title="tedfhdfhst"></a>
<?php
}
?>
</div>
</body>
</html>
';
my $regex = qr/<\?php(.*?)\?>/sp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";