import Foundation
let pattern = #"^\s+|\s+$|\s+(?=\s)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
hello there spaces at end.
a b c d
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)