#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s*\|\s*([^=]*?)\s*=(.*)$"
Local $sString = "{{Infobox XYZ" & @CRLF & _
"|first parameter=foo" & @CRLF & _
"|second_parameter= " & @CRLF & _
"|3rd parameter=bar" & @CRLF & _
"|4th=bazzzzz" & @CRLF & _
"|5th= " & @CRLF & _
"|etc.= " & @CRLF & _
"}}"
Local $sSubst = " | $1 = $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)