package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*\|\s*([^=]*?)\s*=(.*)$`)
var str = `{{Infobox XYZ
|first parameter=foo
|second_parameter=
|3rd parameter=bar
|4th=bazzzzz
|5th=
|etc.=
}}`
var substitution = " | $1 = $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}