using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(""([^""]|\\"")*?"")$|^('([^']|\\')*?')$|^(`([^`]|\\`)*?`)$";
string input = @"// Should pass
""doubleQuotes""
'singleQuote'
""thisis'single'insideDouble""
'thisis""double""insidesSingle'
`this is sometext inside back quote`
""sample\""app\""
// Should fail
""thisis""double""insidesDouble""
'thisis'single'insidesSingle'
`this is sometext `inside` back quote`";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}