import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\"([^\"]|\\\\\")*?\")$|^('([^']|\\\\')*?')$|^(`([^`]|\\\\`)*?`)$";
final String string = "// Should pass\n"
+ "\"doubleQuotes\"\n"
+ "'singleQuote'\n"
+ "\"thisis'single'insideDouble\"\n"
+ "'thisis\"double\"insidesSingle'\n"
+ "`this is sometext inside back quote`\n"
+ "\"sample\\\"app\\\"\"\n\n"
+ "// Should fail\n"
+ "\"thisis\"double\"insidesDouble\"\n"
+ "'thisis'single'insidesSingle'\n"
+ "`this is sometext `inside` back quote`";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}