import re
regex = re.compile(r"^(\"([^\"]|\\\")*?\")$|^('([^']|\\')*?')$|^(`([^`]|\\`)*?`)$", flags=re.MULTILINE)
test_str = ("// Should pass\n"
"\"doubleQuotes\"\n"
"'singleQuote'\n"
"\"thisis'single'insideDouble\"\n"
"'thisis\"double\"insidesSingle'\n"
"`this is sometext inside back quote`\n"
"\"sample\\\"app\\\"\"\n\n"
"// Should fail\n"
"\"thisis\"double\"insidesDouble\"\n"
"'thisis'single'insidesSingle'\n"
"`this is sometext `inside` back quote`")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")