$re = '/\*([^\s*](?:[^*]*[^\s*])?)\*/m';
$str = '* n* *n * *bold* * M *
* text* //don\'t match
******** //don\'t match
*text * //don\'t match
* text * //don\'t match
* text* //don\'t match
*text* //match
*Hello World !* //match
*a*
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);