$re = '/^(?!\s*$)(?!.*[ \t]$)(?![-\s])[^`=~!@#$%^&*()[\]\/\\\\{}"|<>?\n]{3,100}$/m';
$str = 'word
word
word
word w';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);