re = /^(?!\s*$)(?!.*[ \t]$)(?![-\s])[^`=~!@#$%^&*()[\]\/\\{}"|<>?\n]{3,100}$/m
str = 'word
word
word
word w'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end