import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?'id'[0-9a-fA-F]{2})(?:-(?'id_to'\\w+))? ([ \\/\\w-]+)(?: [\\/\\w]+ \\d+\\.\\d+)?$";
final String string = "00 Undefined\n"
+ "01 Flight Simulation Device CA 5.2\n"
+ "02 Automobile Simulation Device CA 5.3\n"
+ "03 Tank Simulation Device CA 5.4\n"
+ "04 Spaceship Simulation Device CA 5.2\n"
+ "05 Submarine Simulation Device CA 5.5\n"
+ "06 Sailing Simulation Device CA 5.5\n"
+ "07 Motorcycle Simulation Device CA 5.6\n"
+ "08 Sports Simulation Device CA 5.1\n"
+ "09 Airplane Simulation Device CA 5.2\n"
+ "0A Helicopter Simulation Device CA 5.2\n"
+ "0B Magic Carpet Simulation Device CA 5.7\n"
+ "0C Bicycle Simulation Device CA 5.6\n"
+ "0D-1F Reserved\n"
+ "20 Flight Control Stick CA 5.2\n"
+ "21 Flight Stick CA 5.2\n"
+ "22 Cyclic Control CP 5.2\n"
+ "23 Cyclic Trim CP 5.2\n"
+ "24 Flight Yoke CA 5.2\n"
+ "25 Track Control CP 5.4\n"
+ "26-AF Reserved\n"
+ "B0 Aileron DV 5.2\n"
+ "B1 Aileron Trim DV 5.2\n"
+ "B2 Anti-Torque Control DV 5.2\n"
+ "B3 Autopilot Enable OOC 5.2\n"
+ "B4 Chaff Release OSC 5.2\n"
+ "B5 Collective Control DV 5.2\n"
+ "B6 Dive Brake DV 5.2\n"
+ "B7 Electronic Countermeasures OOC 5.2\n"
+ "B8 Elevator DV 5.2\n"
+ "B9 Elevator Trim DV 5.2\n"
+ "BA Rudder DV 5.2\n"
+ "BB Throttle DV 5.2\n"
+ "BC Flight Communications OOC 5.2\n"
+ "BD Flare Release OSC 5.2\n"
+ "BE Landing Gear OOC 5.2\n"
+ "BF Toe Brake DV 5.2\n"
+ "C0 Trigger MC 5.2\n"
+ "C1 Weapons Arm OOC 5.2\n"
+ "C2 Weapons Select OSC 5.2\n"
+ "54\n"
+ "C3 Wing Flaps DV 5.2\n"
+ "C4 Accelerator DV 5.3\n"
+ "C5 Brake DV 5.3\n"
+ "C6 Clutch DV 5.3\n"
+ "C7 Shifter DV 5.3\n"
+ "C8 Steering DV 5.3\n"
+ "C9 Turret Direction DV 5.4\n"
+ "CA Barrel Elevation DV 5.4\n"
+ "CB Dive Plane DV 5.5\n"
+ "CC Ballast DV 5.5\n"
+ "CD Bicycle Crank DV 5.6\n"
+ "CE Handle Bars DV 5.6\n"
+ "CF Front Brake DV 5.6\n"
+ "D0 Rear Brake DV 5.6\n"
+ "D1-FFFF Reserved\n";
final String subst = "\\t${id_to:+// 0x${id}-0x${id_to} $3:${name} = 0x${id},}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}