$re = '/(.*)_(.*)\..*_(.*)/';
$str = 'aabb_cc.dd_eeff';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);