#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[\w\.]*\w+\..*?(?=,|\s|$)\K"
Local $sString = "You can go to www.google.com, or if you want a different engine, you can go to https://www.bing.com, whichever you prefer"
Local $sSubst = "/whatever"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)