$re = '/[\w\.]*\w+\..*?(?=,|\s|$)\K/';
$str = 'You can go to www.google.com, or if you want a different engine, you can go to https://www.bing.com, whichever you prefer';
$subst = "/whatever";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;